Difference between revisions of "Development Team/Jhbuild/Ubuntu"

From Sugar Labs
Jump to: navigation, search
(9.04: :::as of 16Aug9 the above became unnecessary)
(9.04: ====4SEP9==== All worked from a full update/ build to run.)
Line 1: Line 1:
 
== Supported versions ==
 
== Supported versions ==
 
===9.04===
 
===9.04===
 +
 +
====4SEP9====
 +
All worked from a full update/ build to run.
 +
 +
====older and may be deprecated====
 
Jaunty (9.04) has [http://dev.sugarlabs.org/ticket/310 a broken D-Bus security configuration] that prevents sugar-emulator from working (because Xephyr cannot work).
 
Jaunty (9.04) has [http://dev.sugarlabs.org/ticket/310 a broken D-Bus security configuration] that prevents sugar-emulator from working (because Xephyr cannot work).
 
On both versions [http://dev.sugarlabs.org/ticket/342 sugar-emulator doesn't work properly if the X server uses evdev as keyboard driver] (because of a Xephyr bug).
 
On both versions [http://dev.sugarlabs.org/ticket/342 sugar-emulator doesn't work properly if the X server uses evdev as keyboard driver] (because of a Xephyr bug).

Revision as of 19:59, 4 September 2009

Supported versions

9.04

4SEP9

All worked from a full update/ build to run.

older and may be deprecated

Jaunty (9.04) has a broken D-Bus security configuration that prevents sugar-emulator from working (because Xephyr cannot work). On both versions sugar-emulator doesn't work properly if the X server uses evdev as keyboard driver (because of a Xephyr bug).

To get sugar to work type at the terminal

 DISPLAY=:0 ./sugar-jhbuild run
This came from the very helpful sdziallas on the irc://irc.freenode.net#sugar.
as of 16Aug9 the above became unnecessary

8.10

Currently intrepid (8.10) is supported.

Prerequites

In order to install sugar-jhbuild, you need git-core and svn.

Installing dependencies

After installing and updating sugar-jhbuild according to the common instructions, you can use this invocation to install all dependencies automatically:

./sugar-jhbuild depscheck -s | sudo xargs aptitude -y install

Fixing RPATH

To work around a bug in the Gnome Python bindings, you need to issue the following commands after installing all dependencies:

sudo aptitude install chrpath
find /usr/lib/python-support/python-gnome2/python2.5/gtk-2.0 \
    /usr/lib/python-support/python-gconf/python2.5/gtk-2.0 \
    -name "*.so" | sudo xargs chrpath -d

PenguinTV

You may have some issues with penguintv on Ubuntu, just interrupt the pull with a CTRL+C, open a shell, repeat the command manually, and accept the certificate permanently.