Difference between revisions of "Karma:Meeting 21 December 2009"
Jump to navigation
Jump to search
m (Reverted edits by KachachanC (talk) to last revision by BryanWB) |
|||
(3 intermediate revisions by 2 users not shown) | |||
Line 1: | Line 1: | ||
Agenda | Agenda | ||
# Coding Style | # Coding Style | ||
+ | when in doubt, use camelCase | ||
+ | constants in all CAPS, w/ _ separating multiple words --> COUNT_ERRORS = 10; | ||
+ | boolean variables should be prefixed w/ "is" "can" or "should" | ||
+ | prefix counters with "count" or "num" | ||
# common HTML mistakes | # common HTML mistakes | ||
# Let's try to use a common js coding pattern | # Let's try to use a common js coding pattern | ||
Line 8: | Line 12: | ||
3) method calls | 3) method calls | ||
− | Unobtrusive JavaScript | + | Unobtrusive JavaScript -- let's try to stick to it |
# common js problems, no blocks around ifs, ' ' eval, ==, var methodName = function(){} | # common js problems, no blocks around ifs, ' ' eval, ==, var methodName = function(){} | ||
# managing code for lessons in repos, versioning | # managing code for lessons in repos, versioning | ||
+ | Bryan will create karma-lesson repo | ||
+ | lessons will have two states "stable" or "unstable", the "stable" commit is tagged "stable" | ||
+ | everything else is unstable | ||
+ | will use repo-naming convention from E-Paath but prefixed w/ "karma_" | ||
# Using draggable()? | # Using draggable()? | ||
+ | Vaibhaw will take look at jquery UI's draggable and see if useful | ||
# Create common widgets? Scorebox? timer? -- yes we need all of them | # Create common widgets? Scorebox? timer? -- yes we need all of them | ||
− | + | Bryan will look at dialog for help, playAgain | |
+ | Bryan will add shuffle() to Karma | ||
# timeline? milestones? | # timeline? milestones? | ||
+ | Vaibhaw will complete all 60 by March | ||
# We need resolution help! at least I do | # We need resolution help! at least I do | ||
+ | Bryan will check w/ Om to see if lesson dimensions will be part of UI design | ||
# Workflow - have Om review it? | # Workflow - have Om review it? | ||
+ | opyadav will review the finished activities |
Latest revision as of 20:53, 19 December 2016
Agenda
- Coding Style
when in doubt, use camelCase constants in all CAPS, w/ _ separating multiple words --> COUNT_ERRORS = 10; boolean variables should be prefixed w/ "is" "can" or "should" prefix counters with "count" or "num"
- common HTML mistakes
- Let's try to use a common js coding pattern
Put code in following order 1) variable declarations 2) method declarations 3) method calls
Unobtrusive JavaScript -- let's try to stick to it
- common js problems, no blocks around ifs, ' ' eval, ==, var methodName = function(){}
- managing code for lessons in repos, versioning
Bryan will create karma-lesson repo lessons will have two states "stable" or "unstable", the "stable" commit is tagged "stable" everything else is unstable will use repo-naming convention from E-Paath but prefixed w/ "karma_"
- Using draggable()?
Vaibhaw will take look at jquery UI's draggable and see if useful
- Create common widgets? Scorebox? timer? -- yes we need all of them
Bryan will look at dialog for help, playAgain Bryan will add shuffle() to Karma
- timeline? milestones?
Vaibhaw will complete all 60 by March
- We need resolution help! at least I do
Bryan will check w/ Om to see if lesson dimensions will be part of UI design
- Workflow - have Om review it?
opyadav will review the finished activities