Difference between revisions of "Development Team/Jhbuild/Debian"

From Sugar Labs
Jump to: navigation, search
(Supported versions: Squeeze isn't good enough any more)
(mention known issues)
Line 12: Line 12:
  
 
  ./sugar-jhbuild depscheck -s | sudo xargs aptitude -y install
 
  ./sugar-jhbuild depscheck -s | sudo xargs aptitude -y install
 +
 +
== Known issues ==
 +
 +
Sugar will currently fail to start up because of [http://bugs.debian.org/648724 Debian#648724]. Until the package maintainer uploads the fix to the official Debian archive, you can build the patched package yourself. [[User:Sascha_silbe|Sascha Silbe]] can provide binary packages for amd64, armel, i386 and maybe powerpc on request.
 +
 +
In order to use [[Activities/Read|Read]], you will need gir1.2-evince-3.0 >= 3.3.90-1, currently only available in [http://wiki.debian.org/DebianExperimental Debian experimental].

Revision as of 16:44, 19 March 2012

Supported versions

Currently Wheezy (testing) and Sid (unstable) are supported.

Squeeze isn't supported any more because Sugar is in the progress of migrating to GTK 3 / Gnome 3, requiring bleeding edge versions of a couple of components.

Prerequisites

In order to install sugar-jhbuild, you need to install git-core, lsb-release, python and subversion:

sudo aptitude install git-core lsb-release python subversion

Installing dependencies

After installing and updating sugar-jhbuild according to the common instructions, you can use this invocation to install all dependencies automatically:

./sugar-jhbuild depscheck -s | sudo xargs aptitude -y install

Known issues

Sugar will currently fail to start up because of Debian#648724. Until the package maintainer uploads the fix to the official Debian archive, you can build the patched package yourself. Sascha Silbe can provide binary packages for amd64, armel, i386 and maybe powerpc on request.

In order to use Read, you will need gir1.2-evince-3.0 >= 3.3.90-1, currently only available in Debian experimental.