Development Team/Jhbuild/Ubuntu

From Sugar Labs
< Development Team‎ | Jhbuild
Revision as of 04:58, 29 May 2011 by Sascha silbe (talk | contribs) (Karmic (9.10) is EOL, so no version of Ubuntu is supported anymore)
Jump to: navigation, search

Supported versions

Ubuntu is currently unsupported because all recent versions lack at least one important package (python-xpcom).

Prerequisites

In order to install sugar-jhbuild, you need git-core and svn.

Installing dependencies

After installing and updating sugar-jhbuild according to the common instructions, you can use this invocation to install all dependencies automatically:

./sugar-jhbuild depscheck -s | sudo xargs aptitude -y install

Significant bugs

Potential pitfalls

  • gtk-recordmydesktop may prevent sugar-emulator from working properly